首页 > 主机面板 > 【经验】Kangle系统不支持Zend解密解决方法
2015
02-02

【经验】Kangle系统不支持Zend解密解决方法

【经验】Kangle系统不支持Zend解密解决方法 - 第1张  | 意林笔记

最近站长新购香港VPS安装了商业版Kangle+EP面板,帮人搬家PHPWEB成品网站时遇到了Zend版本安装问题。

【安装 phpweb 成品网站时候出现的问题】

Fatal error: Incompatible file format: The encoded file has format major ID 1, whereas the Loader expects 4 in /home/ftp/p/phpweb_a/wwwroot/includes/common.inc.php on line 0

经过多方搜寻找到问题是从PHP5.3开始的Zend加密程序改用Zend Guard Loader解析,那问装了kangle,该怎么解决这个问题呢?

那就是更换Kangle开空间时的模板,而且安装了 5217模板之后,必须新建网站才能使用,原空间网站改成5217模板就不行。

下面是安装PHP5217模板命令:

wget http://download.kanglesoft.com/misc/php-5.2.17/php5217.sh -O php5217.sh;sh php5217.sh

php.ini文件:

/vhs/kangle/ext/tpl_php5217/php-templete.ini

安装完后,在你的easypanel应该就有能看到php5217的模板了。

最后编辑:
作者:意林
站长意林,一名80后全职普通上班族,旗下提供HelloIDC免费空间等业务。
捐 赠如果感觉本站不错,请尝试捐助一下,1块也不少!

留下一个回复

你的email不会被公开。